Error 2E0? Please Help!


#1

Hi all, first brew day with brand new Robobrew V3 and encountered an error I fear may mean I have a dead machine as there are no references to it in the manual or online. Was heating my strike water to 170F with both elements and the pump on. Went to check on it and discovered current temp was “2E0”, pump on and both elements’ lights out, despite them being in the on position. 2E0 is an error code, I assume, but I can’t find any reference to it anywhere. Does anyone have any ideas? My apologies if this is an easy fix and I’m overlooking something obvious. Many thanks.

Edit: Robobrew now indicates Error E2–Short Circuit Temperature Probe. How do I fix that? Brew day is now OVER!!! :frowning:


#2

Mate, That doesn’t sound great. Have you tried a factory reset?

From the documentation:

Factory Reset
To reset all the settings on the Robobrew and clear all the stages the fastest way to do
this is by quickly pressing the “+” and “-“ buttons at the same time quickly. Both buttons
must be pressed at exactly the same time in order for this to work.
NOTE: This reset will also reset the calibration figure.


#3

My temperature probe also crapped out, although I did not get an error code - it was simply reading about 50C higher than it was meant to which meant that the elements would not turn off when they reached the required temperature.

I got in touch with the local supplier, who:

  • swore black and blue that there was no problem with the unit
  • implied that I was making the issue up (“we’ve never seen this before” etc)
  • made me do the factory reset mentioned by @Quinny, even though i’d already done it
  • made me adjust the temperature calibration even though it only goes +/- 10C and the sensor was over 50C out
  • still wouldn’t believe that I had correctly done any of the above which prompted me to produce a YouTube video proving the fault

Eventually they conceded that there was a manufacturing defect that they were required by NZ law to take responsibility for, so I sent the unit back and they replaced the temperature probe.

Since then it’s been working well

Good luck!


#4

Tried reset…still a solid “E2”…


#5

Send it back - I assume you’re in America because you’re using Fahrenheit. I don’t know what the consumer laws are in America but I hope there is some kind of warranty


#6

I contacted the reseller I bought it from on Amazon…will see how it goes! Many thanks. Guess will have to use old brew system for the Belgian Dark Strong I was hoping to do today. Out of time, so it’ll have to wait a couple weeks. :cry:


#7

Reseller said I should email Kegland for assistance, but wasn’t able to provide an address. Does anyone have a good (and responsive) contact address at Kegland? I’ve heard they are notoriously bad at customer service, so I’d like that to be proven wrong…


#8

Just push play! You never know.