Serious issues with Canadian Robobrews?


#1

Hello from Nova Scotia! I am a new Robobrew owner and long time participant in our regional brew club. My Robobrew crapped out on the very first brew. There’s a thread on our club page about the Robobrew, and a distressing number are about Robobrews breaking down. Curious to know whether you guys are having similiar issues or if there’s any gossip about recalls, etc. The last post–someone’s elements blew out, but not before overheating so much that they scortched the beer black!–is pretty distressing.

In the thread so far one person’s pump broke on the first brew, one person’s circuit board blew out on their first brew, another person’s circuit board went on their second brew, and another’s elements went crazy. I don’t know the numbers, but we’re not a huge group and only a small percentage of us must own Robobrews, so that’s an alarming number of machines breaking down really fast.

On my machine, in addition to the circuit board crapping out (it was stucking reading 120 C), I also had one of the “lid clamps” come off because of a bad weld and a leak on another spot due to a bad weld, both out of box.

See the thread here. Skip to page two: http://www.brewnosers.org/forums/viewtopic.php?f=3&p=164273&sid=8ec48225b8e88fa6bdda414c3f955f17#p164273


#2

This is concerning… I’m in Ontario and just got mine (a gift) 3 weeks ago. Got mine from OBK.

Are people having issues with getting replacement parts, returns, et c?

Where was the leak on yours?

I read about one person’s circuit board going on Canadian Home Brewing Forum. It looks like he was sent a replacement board.

Mine seems to be running well after 2 brews so far. Though I’m noting some spots of discolouration on the bottom of my pot, in the centre, after the last brew. I don’t want to use an abrasive, so I’ve been waiting to get something less invasive to try to see if I can remove them. If it’s not a deposit of some sort (it’s lighter than the pot) than it means it’s a defect in the material. I really hope not though.


#3

patrickivan:

I got mine from Everwood Ave Brew Shop and they’ve been great on fast replacement parts. I know OBK has been as well. The insides of the Robobrew are pretty simple if you open them up, and swapping out parts is not much of a problem, but I too am a bit freaked out by the number of units that seem to be failing within just a couple of brews. This isn’t a cheap bit of kit… and that one year warranty doesn’t cover all that many brews. (In email exchanges with Everwood, they noted that they had other units that had the circuit board crap out like mine, causing the unit to lock on super high temp readings. They experimented on these units before sending my a new circuit board.)

The leak was on the welded on ‘nut’ just below the valve on the recirculation arm. One of the lid clamps also popped off. Upon inspection, it was spot welded, but only one of the three welds had actually bonded.


#4

Ugh. I hope that’s the end of your issues. You’re right about the cost. Not a cheap tool to brew with.

After my third brew in as many weeks coming up, I’m going to try to do one every 3 weeks. If it’s going to fail, hopefully it’ll happen sooner rather than later.

One fellow on the Canada Home Brewing forum, brews on a crate and installed a washroom exhaust fan under it to help keep the components cooler. I’ll be following suit soon. It certainly can’t hurt as a preventative measure.


#5

I know here in Australia it’s a bit of a case of only hearing complaints from those with issues, so it sounds like it’s all bad. Myself and (hopefully) the majority of other robobrewers seem to be fine.

I’d hope that your warranty/dealer is taking care of these issues… because the robobrew is a great system for the pricetag when it works.

@patrickivan white/chalky residue is fairly normal in my experience and can be taken care of with a PBW soak. I only do a light clean between batches and then every maybe 4 or 5 batches I’ll do a proper soak with PBW which brings it back to as-new shiny steel. If your discolouration is something else maybe share a photo and someone can point you in the right direction.


#6

@brewcow Fair enough statement regarding complaints. It is usually easier for us to complain about every bloody little thing.

I’ll be sure to post a before and hopefully positive after, when I take care of those spots.

My first (and only) two batches resulted in a thick sludge baked onto the bottom of the pot. I never encountered that before with my propane boiling. I’m guessing it may have something to do with such a small surface area. My 40 litre pot of course has a much greater surface area.

I will say, that otherwise, brewing with it has been quite fun. And fast including cleanup. I’ve never brewed back to back (and coming up again) weekends before.

What model do you have, and how long have you been brewing with it?


#7

Makes perfect sense that people share complaints and issues rather than updates of “everything went to plan again”… and I do think and hope the complaints are helping Kegland fine-tune some of these bugs though.

I’ve got the gen 3 and also the original pumpless model. Had both since they came out, so I think 3 years total robobrewing. It replaced a bigger 3V system that had an electric HLT, esky/cooler MT and gas BK. I miss the ability to do double batches but brewing is now something I can do on a quiet weeknight instead of having to dedicate an entire Saturday to.


#8

Hey there. I just got my robobrew this week and did my first batch last night. I was doing my boil then all of a sudden the temperature spiked to 244F. I can’t seem to clear that number, thinking my thermometer is now stuck at that. Even after I cleaned the machine and turned it back on it still reads the same. Any feedback on how to fix this?
Thanks,
Liam


#9

Did you try factory reset? Per the instructions:

Factory Reset
To reset all the settings on the Robobrew and clear all the stages the fastest way to do
this is by quickly pressing the “+” and “-“ buttons at the same time quickly. Both buttons
must be pressed at exactly the same time in order for this to work.
NOTE: This reset will also reset the calibration figure.


#10

That’s exactly what happened to me and a number of other people I’ve talked to. (Mine stuck at about 120 C.) Replacing the circuit board fixes it. Apparently, in Canada at least, they’ve released a new circuit board that is supposed to handle things better. It’s a pretty easy swap to change them out, but also a bit disturbing in terms of quality control that they went out of factory like this.


#11

Hey there. Ya I tried that but nothing was happening. The screen would come back to 244F no matter what. I did contact the place where I purchased it, they recommended the same. In the end they figure the circuit board needs replacement. Thanks for the suggestions. I was trying everything.


#12

How long have you had your circuit board replaced now? Any further issues. Sounds like the store I bought it from is requesting a new board. Can’t believe it happen my first brew.


#13

Happened on my first brew too. :frowning:

I did a batch after with no issues. Hopefully the new board solved it.


#14

And it looks like they’ve updated the circuit board on new Robobrews in 2019. Though I’m having a hell of a time figuring out what exactly was the issue. I mean, clearly they knew there was one, or why would they release a new one?

I’d very much like to know.


#15

Subscribing to this. I just got a Canadian Version form OKB Version 3.1 with updated controller board. Not tried it yet. but hope to unpack and clean it this week.

Bruce


#16

Just had this experience with my V3. Just after brewing a batch I was running a cleaning cycle at about 65c when I heard a loud pop and the heaters stopped working. Done about 9 or 10 brews up to this point with no problems. The local home brew shop Barleys in BC put in my warranty claim really quickly and I hope to get my new boards in soon.


#17

I bought a 65L Brewzilla I wired it with a new US plug everything working good so far except the pump stops working when it reaches 110F and above. If I leave the pump running when it is cold it will stay running for hours. As soon as my mash hits around 110 the pump binds and stops pumping.
Any body else have this issue?


#18

I have been using the 3.1 version since the start of the year with no problem (knock wood)